Repository navigation
chore(deps): upgrade all dependencies; next 16.4.3 (RCE GHSA-2464-fhr4-w9xw) - #98
Conversation
…4-w9xw) - next 16.3.8 -> 16.4.3 (GHSA-2464-fhr4-w9xw, GHSA-673q-mjm6-r5xr) - every dependency to latest; majors: @anthropic-ai/sdk 1, eslint 10, commander 15, chalk 6, ora 9, dotenv 18, typescript 7 (root, cli), @profullstack/bridges 0.2, x402-gateway 0.13 - cli tsconfig lists types: ["node"] (TS 7 no longer auto-includes @types) - held: typescript 6.0.3 in apps/web (typescript-eslint does not support TS 7) - overrides: js-yaml, browserslist, zod, baseline-browser-mapping; brace-expansion re-resolved to 1.1.21 / 5.0.12 - bun 1.4.4 (image + packageManager) - bun audit: 3 critical / 22 high -> 0 Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com>
|
Warning Review the following alerts detected in dependencies. According to your organization's Security Policy, it is recommended to resolve "Warn" alerts. Learn more about Socket for GitHub.
|
ThreatCrush Security Scan38 finding(s) MEDIUM: 32 | LOW: 6
Snippets are redacted; ThreatCrush never prints matched credential material. |
Fleet dependency upgrade (2026-10-26). Driver: Next.js unauthenticated RCE advisories GHSA-2464-fhr4-w9xw and GHSA-673q-mjm6-r5xr.
Security
next16.3.8 -> 16.4.3bun audit: 3 critical / 22 high / 11 moderate / 5 low -> 0. Overrides:js-yaml ^4.3.2,browserslist ^4.29.4,zod ^4.6.7,baseline-browser-mapping ^2.11.33; nestedbrace-expansionentries re-resolved to 1.1.21 / 5.0.12Majors taken
types: ["node"])Held
typescript6.0.3 in apps/web, not 7: typescript-eslint refuses TS 7Gate (local)
eslintnot installed for apps/cli, exit 127)search amazonagainst prod)docker build -f .nixpacks/Dockerfilesucceeds (Next 16.4.3); booted image serves/and/stores200 (/api/health503 locally without a DB)🤖 Generated with Claude Code